“Could not create the index.html file” en tinthumb.php

Logo Timthumbtimthumb es un pequeño script PHP que nos permite de forma simple mediante parámetros GET, redimensionar, recortar o hacer zoom sobre imágenes. Por esta utilidad, ha sido usado ampliamente en temas WordPress y en otros muchos sitios. Aunque tiene cierta fama por su seguridad (por sus fallos, a priori todos ya resueltos), su uso conlleva alguna problemática de vez en cuando.

Uno de los errores que pueden aparecernos es el que ilustra el título de esta entrada: “Could not create the index.html file” y que puede aparecer sólo o en compañía de otros errores típicos que en otra ocasión trataremos. read more

Leer más » 1 Comentario

Impresora

Leer más » 8 Comentarios

Lo mejor de mi RSS del 27 de agosto al 2 de septiembre

Leer más » 1 Comentario

Fatal error: Allowed memory size of N bytes exhausted en PHP

Uno de los mayores problemas de usar WordPress, es que a pesar de ser un sistema bastante ligero, llega un momento en el que como no tengamos cuidado, puede llegar a ocupar muchos recursos. De cómo aligerar WordPress, he hablado y hablaré (de forma presencial por cierto en la próxima WordPress Meetup Córdoba que es ya mismo) pero esta no es la idea de esta entrada.

La idea de esta entrada es: no puedo aligerar WordPress por cualquier razón (no hay más que aligerar, falta de tiempo…) y el espacio que direcciona de memoria RAM se ha agotado. El indicativo de este problema es un mensaje que dice lo siguiente:

Fatal error: Allowed memory size of N bytes exhausted en PHP

La solución, intentar ampliar la memoria que tenemos disponible para PHP y por lo tanto para WordPress. ¿Cómo? Iremos intentando cada una de estas acciones.

Dentro de php.ini

Si tienes acceso al php.ini global o en su defecto, tienes un php.ini disponible en tu cuenta compartida, busca la línea:

memory_limit = 32M;

Y sustitúyela por esta otra:

memory_limit = 64M;

Leer más » 3 Comentarios

Tres aplicaciones para conectarte por consola serie

La mayor parte de los sistemas Linux embebidos como routers, servidores o dispositivos de almacenamiento en red (NAS) incorporan una interfaz por consola (puerto serie RS-232). Así, tenemos un control total de la máquina desde el arranque, sin esperar a que se levante un servicio determinado por el cual acceder a ésta. En otra entrada trataremos la forma de proveer a un sistema de comunicación serie externa, en ésta veremos cómo acceder a un dispositivo auxiliar por la interfaz serie a través de diferentes comandos.

El comando screen

Usaremos el comando como se propone a continuación:

ahornero@6581-D:~$ screen /dev/device baud-rate
ahornero@6581-D:~$ screen /dev/ttyS0 19200
ahornero@6581-D:~$ screen /dev/ttyUSB0 19200, cs8

El comando minicom

minicom es un comando bastante liviano, mi preferido por consola, para establecer comunicanes serie. El uso es bastante sencillo:

ahornero@6581-D:~$ minicom

Si deseamos configurarlo o establecer una configuración predeterminada:

ahornero@6581-D:~$ minicom -s

El programa PuTTY

Multiplataforma, con interfaz gráfica y con una serie de opciones que nos permiten además de comunicación serie, conectarnos por SSH, telnet, rlogin y RAW sobre el protocolo TCP.

Leer más » 2 Comentarios

Usar Transmission

Transmission es un cliente P2P de código abierto y gratuito para la red BitTorrent y es multiplataforma. Entre las características destaca por la descarga selectiva y priorización de archivos, soporte para transmisiones cifradas, soporte de múltiples Trackers, compatibilidad con enlaces Magnet, creación de Torrents, intercambio de fuentes compatible con Vuze y UTorrent, mapeo automático de puertos y mucho más. Está disponible por defecto en Ubuntu aunque si no es así siempre puedes instalarlo desde el Centro de Software.

Leer más » 1 Comentario

Indicador de carga del sistema en Ubuntu 12.04

Siempre me ha gustado saber gráficamente la carga del sistema: carga de la CPU, cantidad de memoria direccionada, espacio de intercambio en uso, carga media del sistema, cantidad y volumen de las entradas y salidas en los discos… en las versiones de Ubuntu anteriores a Unity, era relativamente simple poner las gráficas en la barra superior del “Indicador de carga del sistema”, en Ubuntu 12.04 no es tan inmediato.

Lo primero que tenemos que hacer es instalarlo, para ello hacemos lo siguiente desde la consola:

sudo add-apt-repository ppa:indicator-multiload/stable-daily
sudo apt-get update
sudo apt-get install indicator-multiload

Aceptamos añadir el nuevo repositorio y tras instalar el programa ya podemos lanzarlo. Para ello desde el buscador ejecutamos “Indicador de carga del sistema” y ya lo tendremos arriba en la barra.

Indicador de carga del sistema en Ubuntu

Leer más » 2 Comentarios

No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock»

Es uno de los fallos más frecuentes por despiste o por novato cuando estamos manejando el sistema de paquetes apt en Ubuntu, Debian o derivadas. Intentamos hacer algo así para instalar un paquete (he puesto libpng-dev como ejemplo):

apt-get install libpng-dev

Y aparece este error:

E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock»
 - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»

¿Cuál es el problema? No tenemos permisos suficientes, por lo que sólo deberemos hacer lo siguiente para solucionarlo:

Leer más » 9 Comentarios

Error Report

Leer más » 5 Comentarios

Lo mejor de mi RSS del 20 al 26 de agosto

Leer más » 2 Comentarios