Sign up with your email address to be the first to know about new products, VIP offers, blog features & more.

BuddyPress 5.0 actualiza el control de contraseña para que coincida con WordPress

Por Posted on 0 No tags 0

Traducido del artículo: “BuddyPress 5.0 to Update Password Control to Match WordPress” de:

Sarah Gooding, junio 10 de 2019

El desarrollo de BuddyPress 5.0 comenzó en diciembre de 2018 después de que se lanzara 4.0.0 en noviembre. El equipo central de BuddyPress no ha publicado una hoja de ruta para lo que vendrá en 5.0, pero las características y correcciones agregadas hasta ahora se pueden encontrar en GitHub en el registro de confirmación.
Una adición notable a la próxima versión importante es que el paquete de plantillas de BP Nouveau se está actualizando para usar el mismo control de contraseña que el que se usa en el núcleo de WordPress. Los usuarios de BuddyPress ahora podrán configurar sus contraseñas utilizando la interfaz de WordPress en la página de registro y en la página de configuración general del usuario.

De forma predeterminada, BuddyPress generará una contraseña segura, pero el usuario aún puede editarla, si es necesario. Si el usuario selecciona una contraseña que es demasiado débil, el botón de envío se desactivará hasta que el usuario confirme que desea continuar marcando la casilla de verificación.

BP Nouveau reemplazó los paquetes de plantillas heredadas de bp en 2018, introduciendo plantillas con JavaScript, integración con el personalizador y más opciones de diseño para los directorios de componentes y navegación de BuddyPress. Como resultado de la actualización del control de contraseña, la plantilla src / bp-templates / bp-nouveau / js / password-verify.js está programada para ser eliminada en BuddyPress 6.0.0, por lo que los desarrolladores querrán tomar nota si l usan el script bp-nouveau-password-Verify como una dependencia para implementaciones de control de contraseña personalizadas.

BuddyPress 5.0 también agrega la depuración específica de BP a la pantalla de información del estado del sitio que se introdujo en WordPress 5.2. Esta versión requerirá WordPress 4.7 o superior para una compatibilidad óptima y las versiones anteriores no serán compatibles. Los propietarios de sitios que se ejecutan en versiones anteriores de WordPress tienen tiempo para prepararse.
Aunque el equipo central y los colaboradores de BuddyPress han publicado varios lanzamientos de seguridad y mantenimiento desde la versión 4.0.0, las reuniones regulares del proyecto han sido esporádicas en 2019. Se esperaba BuddyPress 5.0 a finales de mayo, pero se puede discutir un nuevo calendario en la próxima reunión , que está previsto provisionalmente para el miércoles 12 de junio.

¿Te gustaría escribir para WP Tavern? Siempre estamos aceptando publicaciones de invitados de la comunidad y estamos buscando nuevos colaboradores. Póngase en contacto con nosotros y discutamos sus ideas.

Quién es Sara Gooding

Sarah Gooding es una editora Ninja en Audrey Capital. Cuando no escribe sobre WordPress, le gusta hornear, tejer, juzgar competencias de cerveza y pasar tiempo con su galgo italiano.

Leer entrada anterior
Los volúmenes de comercio de Bitcoin explotan

El 3 de enero del año 2009 se completaron las primeras transacciones económicas con Bitcoin de la historia. A partir...

Cerrar