Sign up with your email address to be the first to know about new products, VIP offers, blog features & more.

WordPress 4.2.3 es una versión de seguridad crítica, soluciona una vulnerabilidad XSS

By Posted on 0 No tags 0

Traducido del artículo: “WordPress 4.2.3 is a Critical Security Release, Fixes an XSS Vulnerability” de:

Sarah Gooding, julio 14 de 2015

Los usuarios de WordPress en el continente americano se despertaron esta mañana para encontrar avisos de actualización en sus bandejas de entrada debido a una vulnerabilidad de seguridad crítica. WordPress 4.2.3 fue lanzado hoy y automáticamente cargado en los sitios que tienen actualizaciones automáticas habilitadas.
Debido a que esta es una versión de seguridad para todas las versiones anteriores de WordPress, los que no tienen habilitada la actualización automática tendrán que actualizar manualmente sus sitios de inmediato. El colaborador Core Gary Pendergast explicó la gravedad del error en el mensaje de la actualización:
Versiones de WordPress 4.2.2 y anteriores están afectadas por una vulnerabilidad de cross-site scripting, que podría permitir a usuarios con permisos de Colaborador o Autor comprometer un sitio. Esto fue informado por Jon Cave y fijado por Robert Chapin, ambos del equipo de seguridad de WordPress.
También hemos solucionado un problema por el que era posible que un usuario con permisos de Suscriptor pudiera crear un borrador a través del Borrador Rápido.
Pendergast dio las gracias a todas las partes que informaron vulnerabilidades de manera responsable al equipo de seguridad de WordPress.
Esta versión también contiene correcciones para 20 bugs (errores) del 4.2, incluyendo uno que podría requerir que se actualiza su base de datos antes de poder volver al administrador.
No todos los usuarios de WordPress que están actualizando serán recibidos con este mensaje, pero si usted lo ve, no se asuste. Está relacionado con una de las correcciones de errores incluidos en el comunicado.
“Fue una corrección de errores en 4.2.3, no portado – algunas versiones de PHP no ejecutaron la actualización utf8mb4 correctamente” dijo Pendergast cuando se le preguntó acerca de la actualización de base de datos requerida.
Por desgracia, en algunos casos, al hacer clic en el botón “Actualizar WordPress Database” se podrían requerir varios intentos. Esto es inusual, pero Pendergast dijo que la mejora de las actualizaciones de base de datos ocupa un destacado lugar en la lista del equipo de prioridades.
Una lista de todos los archivos revisados ​​se encuentra disponible en la página de la versión 4.2.3.

Quién es Sarah Gooding

Sarah Gooding es una Editorialista Ninja en Audrey Capital. Cuando no está escribiendo sobre WordPress, ella disfruta de hornear, hacer punto, juzgar competiciones de cerveza y pasar tiempo con su galgo italiano.

Leer entrada anterior
Lo mejor de mi RSS del 19 al 25 de octubre de 2015: Ubuntu 15.10, copias de seguridad y RedSys con WooCommerce

Llego más tarde de la cuenta pero las obligaciones me obligan, valga la redundancia, pero a cambio de eso, espero...

Cerrar