Sign up with your email address to be the first to know about new products, VIP offers, blog features & more.

Cómo eliminar la notificación de actualización de plugins de WooCommerce / WooThemes

Para los que manejáis WooCommerce es muy posible que no sólo utilicéis este metaplugin de WordPress para llevar a cabo ciertas tareas en vuestra tienda, sino que hagáis uso de otros plugins para añadir cierta funcionalidad. Por cierto, recordaros que WooCommerce es un plugin para montar tiendas sobre WordPress, y lo tenemos incluido en la lista de los mejores plugins para profesionales WordPress.

install_woothemes_woocommerce_linuxhispano

Pues bien, cuando hacemos uso de estas extensiones y son las propias de WooThemes (que el nombre no os confunda, esta empresa empezó haciendo temas y luego ya era tarde para cambiar el dominio raíz) nos aparece un mensaje bastante peleón que no podemos descartar (el clásico botón de “dismiss” para que no vuelva a aparecer no está) ¿Qué hacer? A mi personalmente no me gustan estos mensajes tan contaminantes, parece que nos estén obligando a realizar la acción, y ese tipo de checkers lo único que hacen es sobrecargar nuestra web de consultas a servidores externos nuestros.

El mensaje en cuestión es el de la imagen destacada de esta entrada, y dice así:

Install the WooThemes Updater plugin to get updates for your WooThemes plugins.

¿Opciones? Cualquiera puede pensar que la mejor opción es hacerle un display: none al elemento contenedor por CSS, pero me parece un poco chapucero. ¿Por qué no aprovechamos el mismo hook que levanta para eliminarlo? Lo único que tenemos que hacer es incluir el siguiente código en el funtions.php de nuestro theme. También podemos crearnos un plugin para este propósito, pero nos vamos a quedar con la solución más directa.

Y eso es todo, a olvidarse de tanta notificación 🙂

Leer entrada anterior
iWatch

Cerrar